Episode processing and publishing issues

Incident Report for Megaphone

Resolved

This incident has been resolved.
Posted May 15, 2026 - 17:12 EDT

Monitoring

A fix has been implemented and the team is monitoring the status.
Posted May 15, 2026 - 16:20 EDT

Investigating

The team is currently investigating a number of issues around episode processing and publishing, affecting many recently created episodes.

Older episodes are not impacted.
Posted May 15, 2026 - 13:12 EDT
This incident affected: Megaphone CMS, Content Delivery, and RSS Feeds.