Megaphone CMS Degraded Performance

Incident Report for Megaphone

Resolved

The analytics performance issue has been resolved.
Posted Nov 03, 2025 - 18:44 EST

Identified

The team has identified an issue causing the Megaphone CMS to be slow to load, a fix is in progress. Content Delivery is not impacted.
Posted Nov 03, 2025 - 12:04 EST
This incident affected: Megaphone CMS, Megaphone API, and Megaphone Analytics.