Delayed metrics and impressions data
Incident Report for Megaphone
Resolved
This incident has been resolved.
Posted Sep 29, 2023 - 09:51 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 29, 2023 - 09:11 EDT
Investigating
The team is investigating an issue with delayed data.
Posted Sep 29, 2023 - 08:36 EDT
This incident affected: Megaphone Analytics.