Degraded Performance- Episode Preview Page Loading
Incident Report for Megaphone
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 14:32 EDT
Update
We are continuing to investigate this issue.
Posted Jun 14, 2022 - 14:31 EDT
Investigating
Some users may experience issues loading the episode or order preview page. We are actively investigating and will provide more info as it is available. Please reach out with any Questions.
Posted Jun 14, 2022 - 14:08 EDT
This incident affected: Megaphone CMS.