Inconsistent analytics availability

Incident Report for Megaphone

Resolved

The incident has been resolved
Posted Jun 02, 2025 - 16:47 EDT

Investigating

The team is currently looking at the issue with analytics data not being surfaced in the UI.
Posted Jun 02, 2025 - 14:12 EDT
This incident affected: Megaphone Analytics.