UI Errors

Incident Report for Megaphone

Resolved

This incident has been resolved! Thank you for your patience.
Posted Sep 16, 2025 - 13:38 EDT

Monitoring

The team has implemented a fix, and we are actively monitoring as the resolution takes effect.
Posted Sep 16, 2025 - 13:01 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 16, 2025 - 12:14 EDT

Identified

We are currently experiencing UI error messaging within the platform. The team has identified this issue and a resolve will follow shortly! Thanks for your patience.
Posted Sep 16, 2025 - 12:13 EDT
This incident affected: Megaphone CMS.