Spotify Login not working

Incident Report for Megaphone

Resolved

Spotify Login should now be functioning as expected.
Posted Jun 26, 2026 - 13:31 EDT

Monitoring

The Spotify Login issue has been identified and a fix rolled out.
Posted Jun 26, 2026 - 13:30 EDT

Investigating

The team is currently working on a broader issue with Spotify Login
Posted Jun 26, 2026 - 13:10 EDT
This incident affected: Megaphone CMS.