Degraded orders API
Incident Report for Megaphone
Resolved
The issue has been resolved
Posted Aug 04, 2022 - 06:28 EDT
Investigating
The team is currently investigating an issue with the orders API
Posted Aug 03, 2022 - 17:25 EDT
This incident affected: Megaphone API.