Timeouts and slow performance on Megaphone CMS

Incident Report for Megaphone

Resolved

The incident is now resolved. Episodes that were stuck in processing have been resubmitted.
Posted May 06, 2026 - 21:45 EDT

Monitoring

The fix has been rolled out and the team is monitoring the status.
Posted May 06, 2026 - 18:48 EDT

Identified

The issue has been identified and the team has applied an update.
Posted May 06, 2026 - 18:35 EDT

Investigating

The team is currently investigating issues with 504 timeouts and overall slow performance in the CMS.
Posted May 06, 2026 - 17:15 EDT
This incident affected: Megaphone CMS.