Megaphone analytical data delays
Incident Report for Megaphone
Resolved
This incident has been resolved. Megaphone Analytics is no longer experiencing a delay.
Posted Mar 13, 2024 - 00:04 EDT
Identified
An issue has been identified an issue causing a delay in Megaphone Analytics data for today, March 12th. The team is currently working to resolve this.
Posted Mar 12, 2024 - 14:46 EDT
This incident affected: Megaphone Analytics.