Delay in Spotify Partner Program estimated earnings reporting

Incident Report for Megaphone

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 13:04 EDT

Identified

There is a delay in reporting estimated earnings for the Spotify Partner Program. Earnings after May 26th are not currently visible in Megaphone UI but are captured. The team is working to resolve the reporting issue.
Posted Jun 05, 2026 - 12:07 EDT
This incident affected: Megaphone Analytics.