Delayed episode processing

Incident Report for Megaphone

Resolved

The incident has been resolved.
Posted Jul 22, 2026 - 12:59 EDT

Monitoring

The backlog has cleared and uploads are working.
Posted Jul 21, 2026 - 16:16 EDT

Identified

The issue has been identified and the queue is being processed.
Posted Jul 21, 2026 - 15:53 EDT

Investigating

The team is investigating issues with delayed episode processing
Posted Jul 21, 2026 - 15:24 EDT
This incident affected: Megaphone CMS and Content Delivery.