Widespread Google Cloud issues affecting multiple services

Incident Report for Megaphone

Resolved

The Google incident has been resolved. There will be be follow-ups to ensure all data is loaded correctly.
Posted Jun 13, 2025 - 09:46 EDT

Monitoring

Google has restored services and systems are operational.
Posted Jun 12, 2025 - 21:46 EDT

Identified

The Google Cloud incident outlined here https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW has been affecting numerous aspects of Megaphone functionality. Google is restoring functionality and we expect improvement as their work progresses.
Posted Jun 12, 2025 - 17:09 EDT
This incident affected: Megaphone CMS, Megaphone API, Megaphone Analytics, Content Delivery, and RSS Feeds.