Megaphone CMS - Currently Unavailable
Incident Report for Megaphone
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 18:52 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 29, 2020 - 16:50 EDT
Investigating
The Megaphone CMS is currently experiencing an issue due to an error with an upstream provider. During this time, you will be unable to login to the Megaphone platform. We will provide an update shortly.
Posted Jun 29, 2020 - 16:33 EDT
This incident affected: Megaphone CMS.