Ad Server Pacing Issue - Potential Over Delivery of Ads
Incident Report for Megaphone
Resolved
This incident has been resolved.
Posted May 20, 2020 - 13:11 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2020 - 12:08 EDT
Investigating
We are currently experiencing an ad server issue affecting campaign pacing which can lead to orders over delivering. While we work to resolve this issue our suggestion is to review and pause any campaigns that you may be concerned about.

We have all hands on deck working to resolve this issue quickly.
Posted May 20, 2020 - 11:36 EDT
This incident affected: Megaphone CMS.