Megaphone CMS & Reporting Errors
Incident Report for Megaphone
Resolved
This incident has been resolved. Thanks again for your patience!
Posted Mar 16, 2020 - 14:38 EDT
Monitoring
We are aware of degraded performance and errors within the Megaphone CMS and reporting pages. This incident was due to outages from one of our upstream hosting providers. Our hosting provider reports that these issues are in the process of being resolved, however we are monitoring the situation closely.

We apologize for the inconvenience and will update you as we know more information. Please reach out to our support team with questions.
Posted Mar 16, 2020 - 12:27 EDT
This incident affected: Megaphone CMS.