Upstream Provider Outage - In-App Chat Currently Down
Incident Report for Megaphone
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 11:49 EDT
Investigating
Our in-app chat provider (Intercom) is currently down for emergency maintenance. During this time you will be unable to chat with Megaphone via the in-app chat feature. If you require help or support, please contact support@megaphone.fm for the time being.
Posted Apr 24, 2020 - 11:28 EDT
This incident affected: Megaphone CMS.